Shaving Bytes on JavaScript Conditionals
Whenever you work with JavaScript code, it's as though there's always a shorter way to code something. You thought that a code set was basic until you found out that something was basic...er. One of those code shortcuts can be found with conditions, specifically short if clauses.
A typical short if clause would look something like this:
if(callback) {
callback();
}
Oddly enough this conditional can be made shorter:
callback && callback();
The && is less code than the if(){}; of course only by a few characters but does the same job. You could argue that readability suffers but that's up to individual developers.
![An Interview with Eric Meyer]()
Your early CSS books were instrumental in pushing my love for front end technologies. What was it about CSS that you fell in love with and drove you to write about it?
At first blush, it was the simplicity of it as compared to the table-and-spacer...
![CSS vs. JS Animation: Which is Faster?]()
How is it possible that JavaScript-based animation has secretly always been as fast — or faster — than CSS transitions? And, how is it possible that Adobe and Google consistently release media-rich mobile sites that rival the performance of native apps?
This article serves as a point-by-point...
![Flashy FAQs Using MooTools Sliders]()
I often qualify a great website by one that pay attention to detail and makes all of the "little things" seem as though much time was spent on them. Let's face it -- FAQs are as boring as they come. That is, until you...
![Unicode CSS Classes]()
CSS class name structure and consistency is really important; some developers camelcase classnames, others use dashes, and others use underscores. One thing I've learned when toying around by HTML and CSS class names is that you can actually use unicode symbols and icons as classnames.
It’s worth noting that JS minifiers like Google’s Closure Compiler will do this for you, so the first option is probably better so you get the readability without sacrificing performance. The Closure Compiler outputs it as this:
callback&&callback();
http://closure-compiler.appspot.com/home
and also jshint might shout about the shorter version (depending on the settings of course).
No one writes code for JSHint :)
It’s bad practice though because the code is hard to maintain, debug and extend. I could write a whole blog on why doing this is bad. I see zero benefits.
Agree with comments above. I recently realized that there is no benefits of having expressions in my code so changed jshint settings and now it disallows to use them.
IMO the expression below is pretty readable and it also takes one line:
if (callback) callback();
Agree with the “bad practice” comments.
Sometimes you seem to post stuff just for the sake of it, or to impress beginners.
I appreciate your honesty but impressing people isn’t something that entertains me.
What if I also need to have an else branch?
There’s only “if”, I suppose. Otherwise it’s something like:
While I agree with people’s comments on code readability, I still appreciate posts like this.
I’ve come across the ‘callback && callback();’ syntax before and had to look up wtf was going on. Had I read this post earlier, I would’ve known :)
@Dan i agree with you, posts like this are handy so you understand when you come across it in a project. Sadly, this is clearly lost on a couple of the previous commenters who already know everything there is to know.
I’m not worried about them.
What setting will make jsHint happy?
Code is better than anything, 2 JsPerf :
– http://jsperf.com/if-statement-verses-and-operator
– http://jsperf.com/ternary-vs-and-or-vs-if-else
Readability is important, but for those who like to hyper-optimize their code, this is a great tip.